Author Topic: Another Monitor Issue - K7000  (Read 71 times)

Offline leewoo

  • Level 3: Hologram
  • ***
  • Join Date: Jun 2013
  • Location: Apollo Beach
  • Posts: 222
Another Monitor Issue - K7000
« on: December 06, 2018, 06:03:14 PM »
I have a K7000 in my Mortal Kombat and haven't been able to get it to stay working. I've done a cap kit and a flyback replacement and I've resoldered most, if not all connections. When I turn it on sometimes it's just fine for a little bit but it seems the longer I play it or the more often I play it the picture becomes washed out. It just flips too. It's not like a fading over time. One minute it's fine, one minute it's completely washed out.  Anyone have any idea what this could be?  Thanks.

Sent from my Pixel 2 XL using Tapatalk


Offline paul400

  • Level 7: Khaaaan!
  • *****
  • Join Date: Mar 2011
  • Location: Spring hill, fl
  • Posts: 1408
Re: Another Monitor Issue - K7000
« Reply #1 on: December 06, 2018, 09:12:04 PM »
did you reflow the solder on the rgb  pins on the chassis. looks like your missing red and blue,you can also check the wiring coming from the pcb to the chassis and make sure everything is tight.
taking on monitor chassis repair. wells gardner u2000, k7000 19 and 25 inch, k7201, k7203 , k4600, k4900, k7400, k7500 med rez. electrohome G0-7..
I can also build complete monitors with fresh burn free tubes.

Offline leewoo

  • Level 3: Hologram
  • ***
  • Join Date: Jun 2013
  • Location: Apollo Beach
  • Posts: 222
Re: Another Monitor Issue - K7000
« Reply #2 on: December 06, 2018, 09:59:37 PM »
did you reflow the solder on the rgb  pins on the chassis. looks like your missing red and blue,you can also check the wiring coming from the pcb to the chassis and make sure everything is tight.
I'll give that a shot in the morning. I think I reflowed already but just double check everything from the pcb to monitor.

Sent from my Pixel 2 XL using Tapatalk


Offline leewoo

  • Level 3: Hologram
  • ***
  • Join Date: Jun 2013
  • Location: Apollo Beach
  • Posts: 222
Re: Another Monitor Issue - K7000
« Reply #3 on: December 07, 2018, 12:56:12 PM »
So I checked the connections and everything seemed to be good but the red wire broke off when I was putting it back on. I thought maybe it was brittle and just rewired the entire harness. I thought that was going to solve it but it did not. So I reflowed the RGB pins which I swear I've already done but somehow I must have missed those and the reflow solved it. Thank you!

Sent from my Pixel 2 XL using Tapatalk


Offline paul400

  • Level 7: Khaaaan!
  • *****
  • Join Date: Mar 2011
  • Location: Spring hill, fl
  • Posts: 1408
Re: Another Monitor Issue - K7000
« Reply #4 on: December 07, 2018, 04:27:07 PM »
glad it was an easy fix for you.
taking on monitor chassis repair. wells gardner u2000, k7000 19 and 25 inch, k7201, k7203 , k4600, k4900, k7400, k7500 med rez. electrohome G0-7..
I can also build complete monitors with fresh burn free tubes.